path error

Apr 23, 2009 at 3:42 PM
Edited Apr 23, 2009 at 3:49 PM


I have been using the v1.2.2.0 and everything worked fine.

Today, I tried to update to the latest version of the compressor, and I now get the error message:

--> Failed to read in the data for the path/file [c:\projects\MyProject\Project.Web\Scripts\jquery-1.3.2.js]

The task has the following:

--> JavaScriptFiles="$(ProjectDir)Scripts\jquery-1.3.2.js"

What am I doing wrong?



Apr 24, 2009 at 2:18 AM
Hi Mike,

thanks for using YUICompressor.NET :) Ok, first, a few things.

  1. Can u confirm that the path c:\projects\MyProject\Project.Web\Scripts\  does contain a file called jquery-1.3.2.js (and not .js.min, etc..) ?
  2. Can u try this also ... $(TempBuildDir)Scripts\jquery-1.3.2.js
keep us posted with your results :)
Apr 24, 2009 at 10:10 AM
Edited Apr 24, 2009 at 10:18 AM


Thanks for your quick reply. In answer to your previous message:

1) Yes, the file exists in the specified location (we are not using the ".js.min" files).
2) I tried "$(TempBuildDir)" but it still does not work. Now, the error message is:
     --> Error 10 Could not find a part of the path 'C:\Scripts\jquery-1.3.2.js'.

May 2, 2009 at 4:08 PM


Has anybody any update on this?

May 3, 2009 at 10:56 AM
Hi Mike,

sincere appologies mate. i've been soooo flat out at work + RL.

any chance you could post the following (or some link to an uploaded file with the info in it).

1) your complete msbuild xml file
2) a screenshot of your solution layout / explorer file system. If u can, u can blank out any data u think is private (eg. company names or project names, etc).

I would like to see an overall picture so i can see if i can replicate stuff to pinpoint what is going on (or more to the point, what is not going on).
May 8, 2009 at 2:36 PM

I'm also experiencing this problem. I can't figure out what's wrong... :(